Yes, it is compatible.

Did this answer your question?